AutoDirector forum

The AutoDirector support and advice forum

Script code entered in template html

Post Reply

Page: 1

Author Post
Member
Registered: Jul 2011
Posts: 24
Location: Dublin, Ireland
Hi
I followed instructions for joomla 1.5 integration, placing the script code into the template head tag and then the DIV code into my page body html code.
This works lovely on this page but when any other page is selected from the website menu, eg about us etc, a browser popup appears warning that the Div code for autodirector cannot be found on the page.
Am i doing something incorrect
Also I note there is a joomla fix file for carlist.js on site to correct an issue, do i need this if i am running autodirector 1.9 or is the fix for older versions of autodirector.
Administrator
Registered: Apr 2008
Posts: 324
Hi bochaka,

The Joomla fix is contained in AutoDirector 1.9 (for the record, AutoDirector used to use an 'id' parameter for cars, but Joomla uses that for pages - it's been changed to 'cid').

I suspect Joomla is not at fault in this case. Place the DIV and script tag into the same place on the page - ensure you copy the code from the integration instructions exactly.

I hope that helps. If not, post a URL so we can take a look.
_______________
AutoDirector administrator
Member
Registered: Jul 2011
Posts: 24
Location: Dublin, Ireland
Hi Craig.
The problem was with joomla editor attempting to clean up code. It was leaving the div statement but removing the script code.
THE SOLUTION for anyone else who encounters this is to select no editor in joomla configuration options, then when you go to your page in which you are placing the code, you should see NO EDITOR ICONS. Then simply paste the code into the page and save.
Thanks Craig for the prompt reply.

Post Reply

Page: 1